You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
23 lines
506 B
Nix
23 lines
506 B
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
let
|
|
inherit (lib) mkIf mkMerge mkThenElse;
|
|
annuaire = config.r6d.machines;
|
|
currentMachine = annuaire."${config.networking.fqdn}";
|
|
flags = currentMachine.configurationFlags;
|
|
in
|
|
|
|
mkIf flags.xmonad {
|
|
services.dbus.packages = with pkgs; [ dconf ];
|
|
programs.dconf.enable = true;
|
|
|
|
# Services
|
|
services.xserver.windowManager.xmonad = {
|
|
enable = true;
|
|
enableContribAndExtras = true;
|
|
};
|
|
environment.variables = {
|
|
_JAVA_AWT_WM_NONREPARENTING = "1";
|
|
};
|
|
}
|