You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
33 lines
535 B
Nix
33 lines
535 B
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
let
|
|
inherit (lib) mkIf mkMerge mkThenElse;
|
|
annuaire = config.r6d.machines;
|
|
currentMachine = annuaire."${config.networking.fqdn}";
|
|
flags = currentMachine.configurationFlags;
|
|
in
|
|
|
|
mkIf flags.nixos-manual {
|
|
|
|
# Paquets
|
|
environment.systemPackages = with pkgs; [
|
|
bc
|
|
mailutils
|
|
];
|
|
|
|
# Services
|
|
|
|
## documentation sur ctrl + alt + F8
|
|
documentation.nixos = {
|
|
enable = true;
|
|
};
|
|
|
|
# Réseau
|
|
networking.firewall = {
|
|
allowedTCPPorts = [
|
|
];
|
|
allowedUDPPorts = [
|
|
];
|
|
};
|
|
}
|