You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
24 lines
451 B
Nix
24 lines
451 B
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
let
|
|
inherit (lib) mkIf mkMerge mkThenElse;
|
|
annuaire = config.r6d.machines;
|
|
currentMachine = annuaire."${config.networking.fqdn}";
|
|
flags = currentMachine.configurationFlags;
|
|
in
|
|
|
|
mkIf true {
|
|
|
|
# Select internationalisation properties.
|
|
console = {
|
|
font = "Lat2-Terminus16";
|
|
keyMap = "fr";
|
|
};
|
|
i18n = {
|
|
defaultLocale = "fr_FR.UTF-8";
|
|
};
|
|
|
|
# Set your time zone.
|
|
time.timeZone = "Europe/Paris";
|
|
}
|