You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
19 lines
459 B
Nix
19 lines
459 B
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
let
|
|
inherit (lib) mkIf mkMerge mkThenElse;
|
|
annuaire = config.r6d.machines;
|
|
currentMachine = annuaire."${config.networking.fqdn}";
|
|
flags = currentMachine.configurationFlags;
|
|
in
|
|
|
|
mkIf (flags.developpement-haskell && flags.graphical) {
|
|
|
|
# Paquets
|
|
environment.systemPackages = with pkgs; [
|
|
] ++ (with pkgs.haskellPackages; [
|
|
# Haskell lib
|
|
#threadscope # visualisation des threads (<bidule>.eventlog)
|
|
]);
|
|
}
|