You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
21 lines
471 B
Nix
21 lines
471 B
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
let
|
|
inherit (lib) mkIf mkMerge mkThenElse;
|
|
annuaire = config.r6d.machines;
|
|
currentMachine = annuaire."${config.networking.fqdn}";
|
|
flags = currentMachine.configurationFlags;
|
|
in
|
|
|
|
mkIf flags.swap {
|
|
|
|
# Gestion du swap
|
|
|
|
# https://en.wikipedia.org/wiki/Swappiness
|
|
boot.kernel.sysctl = {
|
|
# le swap est activé (!= 0)
|
|
# le swap est utilisé lorsque (100 - x) % de la mémoire est déja allouée
|
|
"vm.swappiness" = 10;
|
|
};
|
|
}
|