You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
19 lines
728 B
Nix
19 lines
728 B
Nix
{ config, pkgs, ... }:
|
|
|
|
with pkgs.lib;
|
|
|
|
{
|
|
imports =
|
|
[ /nix/var/nix/profiles/per-user/root/channels/nixos/nixpkgs/nixos/virtualisation/virtualbox-image.nix
|
|
/nix/var/nix/profiles/per-user/root/channels/nixos/nixpkgs/nixos/installer/cd-dvd/channel.nix
|
|
/nix/var/nix/profiles/per-user/root/channels/nixos/nixpkgs/nixos/profiles/demo.nix
|
|
/nix/var/nix/profiles/per-user/root/channels/nixos/nixpkgs/nixos/profiles/clone-config.nix
|
|
];
|
|
|
|
# Allow mounting of shared folders.
|
|
users.extraUsers.demo.extraGroups = [ "vboxsf" ];
|
|
|
|
# Add some more video drivers to give X11 a shot at working in
|
|
# VMware and QEMU.
|
|
services.xserver.videoDrivers = mkOverride 40 [ "virtualbox" "vmware" "cirrus" "vesa" ];
|
|
} |