You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

29 lines
773 B
Nix

with import <nixpkgs> {};
stdenv.mkDerivation rec {
version = "master";
name = "random-${version}";
src = fetchgit {
url = "https://gogs.prunetwork.fr/jpierre03/random.git";
sha256 = "1ymdix2vps4shzzaixgxvwpyi2y9fiq5fvh8a3xs5niq4xiz9yai";
};
# OUT shouldn't be needed (and shouldn't have worked), but random
# developers have forgotten to use PREFIX everywhere,
makeFlags = ''
PREFIX=$(out)
'';
buildInputs = [ gcc ];
buildPhase = "make build";
installPhase = "make install PREFIX=\$out";
meta = with stdenv.lib; {
description = "Program thas exit with 0 or 1 randomly";
license = licenses.cc-by-nc-sa-40;
maintainers = [ "Jean-Pierre PRUNARET <jean-pierre+git@prunetwork.fr>" ];
platforms = platforms.linux;
};
}