You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
36 lines
919 B
Nix
36 lines
919 B
Nix
with import <nixpkgs> {};
|
|
|
|
stdenv.mkDerivation rec {
|
|
version = "2018-01-05";
|
|
name = "osm2pgsql-${version}";
|
|
|
|
src = fetchFromGitHub {
|
|
owner = "openstreetmap";
|
|
repo = "osm2pgsql";
|
|
rev = "master";
|
|
sha256 = "0qkfbihnlh367fr013ji4i5228p456wi6y91j8zpbqpg1bblxfbv";
|
|
};
|
|
|
|
buildInputs = [
|
|
boost
|
|
bzip2
|
|
cmake
|
|
expat
|
|
#libressl # TLS, crypto implementation
|
|
lua
|
|
openssl # TLS, crypto implementation
|
|
python python27Packages.psycopg2 # regression tests
|
|
postgresql
|
|
proj
|
|
zlib
|
|
];
|
|
|
|
meta = with stdenv.lib; {
|
|
homepage = http://wiki.openstreetmap.org/wiki/Osm2pgsql;
|
|
description = "osm2pgsql is a tool for loading OpenStreetMap data into a PostgreSQL / PostGIS database suitable for applications like rendering into a map, geocoding with Nominatim, or general analysis.";
|
|
license = licenses.gpl2;
|
|
maintainers = [ maintainers.jpierre03 ];
|
|
};
|
|
}
|
|
|